Compiled using jdk 1.6

Description

Because there is no source version defined in the version.properties, the build process is at the mercy of JDK of the developer running the build. Currently the bobo project is compiled at API version 1.6 which means it can't be used on java 1.5.

There seems to be no reason for the limitation since it would appear that there are no 1.6 APIs used in the source. I rebuilt 2.5.1 from source with no issues.

The solution is simply to add:

ant.build.javac.source=1.5
ant.build.javac.target=1.5

to versions.properties

Environment

all

Assignee

John Wang

Reporter

Raymond Auge

Labels

None

Components

Fix versions

Affects versions

Priority

Major
Configure